- Administration - Added the ability for administrators to configure minimum and maximum RDM client versions
- Dashboard - Added per-widget visibility controls to the Customize dashboard layout dialog
- PAM - Added automatic selection of the current user for PAM checkout requests when they can self-approve
- PAM - Added mandatory ticket number and reviewer assignment options to PAM checkout requests
- PAM - Added support for using any available Windows local account or SQL Server login as a PAM built-in account
- PAM - Improved account discovery result filters and table layout
- PAM - Improved the PAM trial empty states and upsell flow
- PAM - Improved the provider management dashboard, including managed account arrows, enable/disable contrast, and hover actions
- PAM - Prevented adding a PAM account without selecting a provider
- PAM - Reduced scrolling needed to view account discovery results
- PAM - Restored the ability to select accounts from any vault when linking a provider
- Security - Added a warning in the UI when a SCIM token is about to expire or has expired
- Vaults - Updated the admin Vaults page to remove the separate PAM vault type now that PAM and shared vaults are merged
- Administration - Fixed Linux and macOS minimum RDM version settings incorrectly enforcing the Windows minimum version
- PAM - Fixed access denied error when adding a PAM account to a privileged set
- PAM - Fixed account discovery showing vaults that don't support PAM imports
- PAM - Fixed an error approving PAM checkout requests when the approver's time zone is ahead of UTC
- PAM - Fixed checkout approver messages being editable by the requester
- PAM - Fixed custom fields not being editable or viewable for PAM accounts
- PAM - Fixed domain entry heartbeat not populating the SID, UPN, and SAM account name
- PAM - Fixed test connection loading indefinitely when adding a PAM provider
- PAM - Fixed the inability to change the account lifecycle policy mode when a custom password policy was selected
- PAM - Fixed the managed account dialog not appearing after saving a new provider
- PAM - Fixed the missing checkout button on folders
- PAM - Fixed the PAM service failing to start after upgrading against a hub without the migration ledger endpoint
- Security - Fixed password complexity policies losing their custom character set after saving
- Security - Fixed the web client incorrectly showing SSO as enabled when it was actually disabled
- UI - Fixed the description field appearing twice on the entry card