Affected Products

Devolutions Server 2020.3 and earlier, Devolutions Server LTS 2020.3.17 and earlier

Change Log

Initial Publication - 2021-03-30

Severity

High

Product

Devolutions Server

Fix Version

2021.1

Summary

Multiple vulnerabilities were fixed in Devolutions Server.

Overly Permissive CORS Policy (CVE-2021-28048)

Description

An overly permissive CORS Policy exists in Devolutions Server, allowing Cross-Origin requests from any domain. This allows an attacker to interact with the API when a victim visits a malicious website.

Remediation and Workarounds

Update to Devolutions Server 2021.1 or higher, Update to Devolutions Server LTS 2020.3.18 or higher

Severity

High - CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N

Affected Products

Devolutions Server 2020.3 and earlier, Devolutions Server LTS 2020.3.17 and earlier

CVE(s)

CVE-2021-28048

SQL Injection on User Deletion (CVE-2021-28157)

Description

It is possible for an administrator to inject SQL code into a username and execute it by deleting the user.

Remediation and Workarounds

Update to Devolutions Server 2021.1 or higher, Update to Devolutions Server 2020.3.18 or higher

Severity

High - CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Affected Products

Devolutions Server 2020.3 and earlier, Devolutions Server LTS 2020.3.17 and earlier

CVE(s)

CVE-2021-28157

Credits

Marc Olivier Bergeron @ GoSecure